I have recurring infection brewing in my Chronical, what could be going on / wrong???

Here is an excerpt from a recent support ticket we did... Most likely is a ball valve cleaning / sanitation problem if you have recurring infection(s) happening:

 

Have you completely disassembled your Ball Valves? If not you should to clean and disinfect them.

Ball Valves, if not properly cleaned. . . can harbor bacteria.
You can demonstrate this to yourself by simply submerging the Valve in water. . . then open and close it several times while under water.

Keeping the valve "Closed" remove it from the water. . . . Next dry it off inside and out (but keep it closed).

Once you are sure it's 100% dry, open the valve slowly and watch the water come out. There's an area where water and bacteria can be trapped.

When you take the valve apart you'll see exactly where.
The challenge with a Lacto or Aceto infection there may also be spores present. These can withstand Saniclean and boiling water for extended periods.

What I'm going to suggest next will sound wrong, but it's the right thing in this case;
Prepare a solution of Bleach and Water at the rate of 1:20 by volume.
Completely disassemble your Ball Valve and all other components
Place everything into the solution for 10 minutes (no more than 10 minutes)
Rinse everything with Clean water
Toss the entire lot into a bucket of boiling water for a minimum of ~15 minutes
Then use Sani-Clean when you reassemble the components.
I would expect this will kill any bacteria that the components might be hiding.

Was this article helpful?
1 out of 1 found this helpful
Have more questions? Submit a request

Comments

0 comments

Article is closed for comments.